Función ALEATORIO

Este tutorial muestra cómo utilizar el archivo Función RY de Excel a Excel para calcular un número aleatorio.

Función principal de Rand

Descripción general de la función RY

La función RY Calcula un número aleatorio entre 0 y 1.

RY función Sintaxis y entradas:

=RY()

Cómo utilizar la función RY a Excel:

La función RY genera números (decimales) superiores a 0 e inferiores a 1.

=RY()

Rand Ex 01

Nota: RYARRAY es una nueva función a Excel 2019 en adelante y sustituye la función RY. Pero si no tiene la versión más reciente o necesita enviar el archivo para personas que aún no tengan, puede utilizar la función RY para la compatibilidad posterior.

Además de generar números aleatorios superiores a 0 e inferiores a 1, RYARRAY le permite elegir cuántas filas y columnas desea colocar los números aleatorios, escoger el número mínimo y máximo en lugar de sólo 0 y 1 e incluso elegir si desea números enteros o decimales.

Si tiene Excel 2007 en adelante, también puede utilizar RYBETWEEN. Al igual que RYARRAY, le permite elegir el número mínimo y máximo en lugar de sólo 0 y 1. Este ejemplo muestra números aleatorios entre 1 y 100.

Rand Ex 02

Genere números enteros dentro de un intervalo

Como se ha mencionado, RYARRAY y RYBETWEEN lo hacen fácilmente. Con RY, debe hacerlo así:

=ENTERO(RY()*($B$6-$B$3)+$B$3)

Rand Ex 03

La fórmula es básicamente = RY () * (Número máximo – Número mínimo) + Número mínimo. Y envolverlo con un ENTERO para coger el entero.

Genere fechas u horas aleatorias

Si sabe cómo se almacenan las fechas y la hora en Excel, la lógica será la misma que la anterior, ya que se almacenan como números. sólo:

=ENTERO(RY()*($B$6-$B$3)+$B$3)

Rand Ex 04

El tiempo es similar, excepto que es decimal en lugar de un número entero o entero. Por lo tanto, elimine la ENTERO:

=RY()*($B$6-$B$3)+$B$3

Rand Ex 05

Para tenerlos ambos juntos, simplemente añádalos:

=ENTERO(RY()*($B$6-$B$3)+$B$3)+RY()*($C$6-$C$3)+$C$33

Rand Ex 06

Recupera un campo aleatorio

Si simplemente necesita aleatorizaron decimales, RY es perfecto por sí mismo. La mayoría de las veces, sin embargo, queremos recuperar un campo aleatorio. Para coger un empleado aleatorio a B3: B7, por ejemplo, puede utilizar una función RY para asignar a cada empleado y INDICE y K.ESIMO.MAYO para coger un empleado aleatorio:

=INDICE(B3:B7,JERARQUIA(C3,C3:C7))

Rand Ex 07

La función RY aleatoritzarà los números de C3: C7. JERARQUIA compara el número aleatorio de la celda C3 entre C3: C7 y clasifica el número en orden descendente. ,0843531593276469, por ejemplo, ocupa el número 3 entre C3: C7. INDICE coge la fila número 3 de B3: B7 y es Sebastian Thompson.

Pulse la tecla F9 y la función RY volverá a calcularse. El valor de 0.180669763264754 en la celda C3 se encuentra ahora en el puesto 5 entre los números de C3: C7 y, por tanto, muestra el 5th fila a B3: B7 y esto es Cairo Mccall.

Rand Ex 08

Tenga en cuenta que, aunque es muy improbable que la función RY genere un número duplicado, aunque es teóricamente posible.

Recupera un campo aleatorio sin duplicados

Para asegurarse de que no haya duplicados, añadir un CONTARSI a la fórmula.

=INDICE($B$3:$B$7,JERARQUIA(C3,$C$3:$C$7)+CONTARSI($C$3:C3,C3)-1)

Rand Ex 09

En el ejemplo anterior, hay dos instancias de ,834312895315874. Por lo tanto, ambos clasifican lo mismo en 5. Con CONTARSI menos 1 añadido, el primer rango de ,834312895315874 sería 5 + 1 -1 (5) y el segundo rango de ,834312895315874 sería 5 + 2 – 1 (6 ) y, por tanto, recoger diferentes filas.

Función RY a Hojas de cálculo de Google

el RY La función funciona exactamente igual a Hojas de cálculo de Google que a Excel:

Función Rand de Google

Notas adicionales sobre la función ALEATORIO

Utilice la función RY para calcular un número aleatorio entre 0 y 1.
=aleatorio()

Video tutorial de la función ALEATORIO en excel

 

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *