Función ESTEXTO

Este tutorial muestra cómo utilizar el archivo Función ESTEXTO de Excel a Excel para comprobar si una celda es texto.

Descripción de la función ESTEXTO:

La prueba de función ESTEXTO si la celda es texto. Devuelve VERDADERO o FALSO.

Sintaxis y entradas de la función ESTEXTO

=ESTEXTO(VALOR)

Valor – El valor de la prueba

Cómo utilizar la función ESTEXTO

La función ESTEXTO prueba si el contenido de la celda es texto. Si la celda contiene texto, vuelve VERDADERO, de lo contrario, vuelve FALSO.

=ESTEXTO(A2)

Números almacenados como texto

Al trabajar con Excel, es probable que surjan números almacenados como texto. Excel trata estos números almacenados como texto como texto y no como números, lo que puede presentar problemas para sus fórmulas. Una opción es utilizar la función VALOR para convertir un número almacenado como texto en un número.

En cambio, en cambio, es posible que desee probar si un valor de celda contiene texto. Fíjese en cómo la función ESTEXTO devuelve VERDADERO si encuentra un número almacenado como texto.

=ESTEXTO(A2)

Texto del almacén numérico

Si es texto

Normalmente, después de realizar una prueba lógica, desee hacer algo basado en el resultado de esta prueba. La función SI se puede utilizar para realizar diferentes acciones si una sentencia se evalúa como VERDADERO o FALSO. Lo utilizamos con la función ESTEXTO.

=SI(ESTEXTO(A2),"text", "not text")

Validar la entrada de celda

Un uso de la función ESTEXTO es validar el contenido de una celda. Por ejemplo, es posible que tenga un formulario de entrada que requiera un valor de texto. Con la función ESTEXTO puede probar si el usuario ha introducido un valor de texto, avisándole si no.

=SI(B2="","",SI(ESTEXTO(B2),"","Invalid Entry"))

Validar la entrada de celda

Validación de datos: forzar la entrada de texto

El ejemplo anterior fue la validación de datos “débil”; el usuario puede ignorar el mensaje de advertencia. En lugar de ello, podemos utilizar ESTEXTO dentro de Validación de datos para no permitir valores que no sean de texto.

=ESTEXTO(B2:B5)

Validar la validación de datos

Error de validación de datos

Compruebe si alguna celda del intervalo es texto

Para comprobar si alguna celda de un rango de celdas es texto, podemos utilizar la función ESTEXTO junto con la función SUMAPRODUCTO.

=SI(SUMAPRODUCTO(--ESTEXTO(A2:C2))>0, "Yes", "No")

Siga el enlace anterior para obtener información sobre el funcionamiento de esta función.

Resalte las celdas que contienen texto

Un último que puede hacer con la función ESTEXTO es resaltar las celdas que contienen texto. Lo podemos hacer creando un formato condicional basado en una regla.

  1. Seleccione todas las celdas que desee comprobar
  2. Ir a Menú Superior > Formato condicional > Nueva norma
  3. Seleccione “Utilice una fórmula para determinar qué celdas debe formatear
  4. Introduzca la fórmula = ESTEXTO (A2)
  5. Haga clic en el botón Formato y elija el formato que desee
  6. Haga clic en Aceptar dos veces para salir y guardar.

Validación de datos

Otras funciones lógicas

Las hojas de cálculo Excel / Google contienen muchas funciones lógicas para realizar otras pruebas lógicas. He aquí una lista:

Funciones SI / IS
iferror
iserror
ISNOD
iserr
es en blanco
es número
istext
isnontext
isformula
islògic
isref
es igual
isodd

ESTEXTO a Hojas de cálculo de Google

La función ESTEXTO funciona exactamente igual a Hojas de cálculo de Google que a Excel.

ESTEXTO Ejemplos a VBA

También puede utilizar la función ESTEXTO a VBA. tipo:
application.worksheetfunction.istext(value)

Ejecución de las declaraciones VBA siguientes

Range(“C2”) = Application.WorksheetFunction.IsText(Range(“B2”)) Range(“C3”) = Application.WorksheetFunction.IsText(Range(“B3”)) Range(“C4”) = Application.WorksheetFunction.IsText(Range(“B4”)) Range(“C5”) = Application.WorksheetFunction.IsText(Range(“B5”))

Para los argumentos de función (valor, etc.), puede introducir directamente a la función o bien definir variables para utilizarlas.

Video tutorial de la función ESTEXTO en excel

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *