Ejemplos de funciones de TEXTO

Este tutorial muestra cómo utilizar el archivo Función de texto de Excel a Excel.

Descripción general de la función de texto

La función TEXTO devuelve un valor convertido a texto con un formato especificado.

Función TEXTO Sintaxis y entradas:

=TEXTO(value, format_text)

valor – El valor a formatear
format_text – El formato de texto a aplicar

Cómo utilizar la función TEXTO a Excel:

La función TEXTO toma un valor (número) y lo convierte en un texto con un formato concreto que elija.

=TEXTO(B3,"mmm d, dddd")

pico 01

La función TEXTO es sobre todo como formatear celdas. Por lo tanto, si no está seguro de cuál debe ser el segundo argumento, busque a Formato Cells.

Por ejemplo, haga clic con el botón derecho en B3 y elija Formato de celdas. Puede ver todos estos códigos de formato a introducir.

formato PIC

Pero tenga en cuenta que el texto no funciona bien con los cálculos, por lo tanto, tenga en cuenta si es necesario. A continuación se muestran algunos escenarios para utilizarlo.

Cadena combinada con TEXTO

Si aún no lo saben, las fechas se almacenan como números de serie. Sólo se formatean para presentarse como fecha. Por lo tanto, si combina una cadena (texto) y la celda con la fecha, se mostrará como números.

="Goods were delivered on "& B3

PIC 02

Por lo tanto, tenemos que utilizar la función TEXTO para convertirla de valor a texto.

="Goods were delivered on "&TEXTO(B3,"mmm d, dddd")

PIC 03

TEXTO del día de la semana

Puede que necesite el día de la semana en el informe y no la fecha en sí, por lo que esto puede ser útil.

=TEXTO(B3,"ddd")

PIC 04

Más ejemplo de la función TEXTO con Date

En la tabla siguiente se muestran más ejemplos que nos ayudan a precisar información diferente de la fecha.

Fecha del texto

TEXTO para valores separados por comas

De manera similar a las fechas, los números separados por comas no son más que una presentación. El valor real de B3 es 34000.4, pero formateado para mostrar mil separadores y 0 decimales. Combinándolos se mostraría esto:

=B3&" of sales were made this month."

PIC 05

Puede volver a utilizar TEXTO para asegurarse de que tenga los mil separadores y los 0 decimales.

=TEXTO(B3,"#,##0")&" of sales were made this month."

PIC 06

TEXTO con números fijos

Es posible que tenga una columna de identificadores en la que desee establecer un número de corrección (por ejemplo, 4 dígitos). Puede utilizar:

=TEXTO(B3,"0000")

PIC 07

TEXTO con porcentajes

Al igual que las fechas y los números con mil separadores, los porcentajes también son sólo una presentación. El valor detrás del 10% es de 0,1 y es posible que no desee que se muestre así.

="There was a "& B3 &" decrease in cost."

PIC 08

Puedes utilizar:

="There was a "&TEXTO(B3,"0%")&" decrease in cost."

PIC 09

Más ejemplo de la función TEXTO con Number

En la tabla siguiente se muestran más ejemplos que nos ayudan a Exacta un formato diferente del número.

Número de texto

Convertir valores en números de teléfono

si consideramos el número de teléfono de EE.UU., contiene 7 dígitos para el número de teléfono local y con el código del país se muestra con 10 dígitos.

Podemos identificar el número local si es inferior a 9999999 y, a continuación, podemos utilizar el formato ### – #### para mostrar el número de teléfono local, resto todo lo que podemos mostrar con el código a (###) ### – #### formado.

La siguiente función y captura de pantalla muestra esta fórmula de texto de Excel.

=TEXTO(A2,"[<=9999999]###-####;(###) ###-####")

Convertir a número de teléfono

TEXTO a Hojas de cálculo de Google

La función TEXTO funciona exactamente igual a Hojas de cálculo de Google que a Excel:

Envía un texto en la hoja de Google

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *